Home Evinrude

IT SHOULD HAVE BEEN EASY BUT....

snapperwhippersnapperwhipper Posts: 131 Deckhand
The last time I went out in my 17' AS with a 1986 90 HP Johnson I noticed it ran a little warmer than normal and the impeller has not been replaced in 5 or so years so ok lets install a water pump kit. I purchase a OMC kit and get a friend to help (I'm old) so I battle past the shift linkage, off comes the gear case and while the old impeller is worn it really doesn't look that bad. After watching some videos on you tube and following my shop manual as best as I could it goes back together OK. Hook up the hose to the ear muffs fire it up and all looks well, water comes out the exhaust and the pee hole and everywhere its supposed to but I notice my water pressure gauge is reading lower than before when idling. Well I go for a test run and before I go 100 yards the hot horn comes on I say *%#[email protected]! and idle back to ramp, It cools down when idling. WHAT DID I DO WRONG? There was nothing covering the intake, It just has low pressure! Is it possible the little hose that connects to the top of the pump could have not lined up correctly? I guess its coming back off but I would like some thoughts on why this happened and get it right this time! Thanks in advance for any help. Mike

Read more: http://forums.floridasportsman.com/showthread.php?201081-IT-SHOULD-HAVE-BEEN-EASY-BUT#ixzz3k1PVN3sM
When all else fails...jiggle that wire:\

Replies

  • snapperwhippersnapperwhipper Posts: 131 Deckhand
    Got it grommet installed upside down I hate doing stuff twice!
    When all else fails...jiggle that wire:\
  • BillgranBillgran Posts: 350 Deckhand
    Low water pressure and overheating could be from a number of things.

    Did the water tube enter the impeller housing grommet seal without being folding it over? Was a new grommet installed? Did you remember the oring under the impeller and under the impeller cup? Did you install the whole factory kit or only an impeller? Do the complete kit for that old a motor and for the impeller being in for 5 years.
    *****************************************


    "There is never just one thing wrong with a boat"
    --- Travis McGee


    ******************************************
  • snapperwhippersnapperwhipper Posts: 131 Deckhand
    First I did install the complete OMC water pump kit and yes the grommet inside the water pump did get folded into the impeller. I saw the error of my ways and corrected the problem and my water pressure gauge looks good. As soon as the weather clears I'll take it out for a test spin.
    When all else fails...jiggle that wire:\
Sign In or Register to comment.
Magazine Cover

GET THE MAGAZINE Subscribe & Save

Digital Now Included!

SUBSCRIBE NOW

Give a Gift   |   Subscriber Services

Preview This Month's Issue

Buy Digital Single Issues

Don't miss an issue.
Buy single digital issue for your phone or tablet.

Buy Single Digital Issue on the Florida Sportsman App

Other Magazines

See All Other Magazines

Special Interest Magazines

See All Special Interest Magazines

GET THE NEWSLETTER Join the List and Never Miss a Thing.

Get the top Florida Sportsman stories delivered right to your inbox.

Advertisement

Phone Icon

Get Digital Access.

All Florida Sportsman subscribers now have digital access to their magazine content. This means you have the option to read your magazine on most popular phones and tablets.

To get started, click the link below to visit mymagnow.com and learn how to access your digital magazine.

Get Digital Access

Not a Subscriber?
Subscribe Now