2000 Yamaha 2 stroke 115 -bogging

FishInFLFishInFL Posts: 2,183 Captain
My engine is currently running fine at idle but bogging down at higher speeds, so thinking fuel is being obstructed. I just replaced racor water/fuel separator. What other filters should I be looking for? I am betting some screen is probably obstructed with sediment but not sure where to look. Thx in advance

Replies

  • snookaffinitysnookaffinity Naples, FLPosts: 1,022 Officer
    "It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt." - Mark Twain
  • aboveboredabovebored Posts: 1,237 Officer
    might need carb rebuild
  • rehartlinerehartline Posts: 738 Officer
    I have the 2003 and the same problem (twice). Started fine, idled fine, ran low speed fine. As soon as you power up it boggs down. Both tines it was gummed up carbs due to water in the fuel. After the second carb go through I paid close attention to adding Startron to my fuel and installed a Racor water separator/filter. No problems whatsoever ever since. It's been several years.
  • gitthenetgitthenet Posts: 254 Deckhand
    I have the 2001 version of that motor. I had the opposite problem, wouldn't idle, ran better above 1600 rpm or so. Those carbs have lots of SMALL orfices that can clog easily from old ethanol gas. Carbs got rebuilt and a proper sync-n-link was done. All good now. I also installed a Racor 10 mm fuel/water separator. I use only non-ethanol now.
  • gitthenetgitthenet Posts: 254 Deckhand
    I also had that problem earlier, had to pump the bulb to keep it running. I changed the fuel pump, fixed the problem.
Sign In or Register to comment.