Home Egret Boats

Minn Kota Riptide Ulterra will not stow and spins clockwise

kerleekerlee Posts: 74 Deckhand
I have had a MK Riptide Ulterra since Nov 2015 and it has worked flawlessly until this morning. Deployed it as usual, but when we tried to stow it with remote, it would trim up partially then spin clockwise and wrap the cord, until we cut the power to the unit from the perko switch or hit the stow/deploy button on the remote. We tried the reset procedure described in the manual and it did the same thing, until we cut the power. We tried using the power button at the base to initiate the stow procedure and it would do the same thing but we could abort by pushing the stow button and not have to cut the power. We even tried spinning it counter -clockwise and moving the cord over the head to give a chance for more clockwise revolutions, but no success. The trolling motor would otherwise work well, we just could not get it to stow. The last option was to pull the side plate, which we did not do as that is a guaranteed trip to the factory or authorized service center. I have a quick release mount so we were able to pull the TM off when it was almost at the bow stop on the trailer. Unfortunately, this is a holiday weekend and MK will be closed until Wednesday. Anybody else having/had this problem and have a solution. I could not find this problem anywhere on-line. I posted this on HT as well

Thanks in advance.

Kerry

Replies

  • FlatsBoyFlatsBoy Posts: 1,392 Officer
    Sounds like one of the famous Minnkota features that they never tell you about that could happen one in a million! Lol
    :funnypost
    Another reason I'll stick with the Motorguide XI5
  • kerleekerlee Posts: 74 Deckhand
    Just wanted to provide a follow-up. It may help someone else out down the road. I looked around on the web for a solution and saw a couple of posts about a magnet becoming dislodge when they first released the ulterra models. This was addressed when the saltwater models were released. I still went looking to confirm I had the magnet in place by removing the panel on the right side as well as the black plastic cradle. As far as I could tell the magnet was still in place ( see pic, blue paint on the lever). Everything looked ok but I did not plug it back in. I dropped it off at the local authorized service center and they turned it around in one day. They said that the magnetic switch must have gotten stuck? but when I pulled the black side panel off, I must have released it as the trolling motor was working fine when they plugged it in. When they blocked the lever switch they could re-create the problem. They felt that is must have gotten stuck in the stowed position when the TM deployed therefore the TM didn't know it was deployed and could not stow itself. In any case, the service center said that my magnet was fine and they did not see a lot of issues with the Ulterra's. They did say that I could fix this on the water were it to occur again by removing 2 phillips' screw to take the side plate on the starboard side off. Then removing the black plastic cover which also serves as a cradle for the TM. You will need an allen wrench to do this. I now have one in my boat for this purpose. They said to make sure the lever with the spring moves.
Sign In or Register to comment.