Trim tab issue
REPORTSREGIONSFORECASTPHOTOSBOATINGHOW-TOSPORTFISHGEARVIDEOSSTORE
Results 1 to 3 of 3

Thread: Trim tab issue

  1. #1
    Junior Member
    Join Date
    Jun 2011
    Location
    Miami
    Posts
    9

    Trim tab issue

    Hello to All,

    I have a '95 Hewes that came with Bennett trim tabs... They have worked flawlessly, but recently when I use them the fuse blows. I replace the fuse, and a few seconds after I use the tabs it blows the fuse again. Any suggestions on how I can diagnose the problem? Is it the switch or the pump?


    I appreciate any help. thanks.

  2. #2
    Senior Member
    Join Date
    Jun 2011
    Posts
    146
    Blue,

    The first thing to do is check all the connections for corrosion, particularly both ends of the black ground wire.

    Then do step 3 and look at step 6 below and let me know the results,

    Tom McGow
    Bennett Marine

    Fluid: Automatic Transmission Fluid (ATF) any type. Hydraulic Power Unit is self bleeding, running the Trim Tabs up and down 3-4 times will purge air from the system.

    Fuse: 12 volt system use 20 amp in-line fuse on positive. (24v & 32v use proportionately smaller)

    Red= Port Valve
    Green= Starboard Valve
    Blue=Motor Forward (pump pressure)
    Yellow= Motor Reverse (pump retract)
    Black on HPU=Ground
    Orange on Helm=Control Positive

    Troubleshooting

    1.If one side is not operating reverse hydraulic lines on the front of the Hydraulic Power Unit to determine if the malfunction is in HPU or actuator / hydraulic lines. If after reversing the lines symptom shifts to the other side the malfunction may exist in HPU. If the symptom remains on the same side, malfunction may exist with the actuator / hydraulic lines

    2. Is the unit receiving a solid 12 volts? Low voltage will some times cause the solenoids to not open preventing the tabs from moving even though the pump motor is running.

    3. Conduct the following test:
    Remove the wires from the helm control and touch together as follows:
    Operation=Reaction
    Orange (+), blue, red= Port trim tab down
    Orange (+), blue, green=Starboard trim tab down
    Orange (+), blue, red, green= Both trim tabs down
    Orange (+), yellow, red= Port trim tab up
    Orange (+), yellow, green=Starboard trim tab up
    Orange (+), yellow, red, green= Both trim tabs up

    If the trim tabs function correctly for each wire grouping then the switch is at fault. Also note that any loose or missing screws on the back of the switch (whether a wire is connected there or not) can cause the pump to malfunction.

    This test may also be done right at the pump by substituting a "hot lead" for orange. There is usually a connector to the wire harness within a foot or so of the pump. You want to check this connection for corrosion. You may wish to cut the connector off on the pump side and try the test on bare wires.

    4. If you suspect corrosion on the wire connector near the pump, cut it out, test as above and reconnect using butt splices.

    5. If you conclude the problem is in the pump, contact me. Bennett Trim Tab Systems carry a five year warranty.

    6. Check to see if there is a relay in line on the wiring harness near the hydraulic power unit. If there is it is an Interrupter Relay (IR1000). It prevents the system fuse from blowing if you try to actuate one trim tab up and the other down at the same time. After you test as outlined above, try removing the relay from the wiring harness and retest the unit.(Note: the interrupter relay is no longer used in current Bennett Trim Tab systems and has been replaced with a Switches that "lock out" preventing a blown fuse).

  3. #3
    Junior Member
    Join Date
    Jun 2011
    Location
    Miami
    Posts
    9
    Thank You Tabman,
    That is a lot of great information! I will test it out this weekend and let you know what happens.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •